Bad Boy Blog, an unofficial Diddy and Bad Boy fan blog

Bookmark and Share

BBCode UID in signature lost when updating users in ACP

This forum is for questions and discussion pertaining to the phpBB forum software itself, as well as any phpBB 2 related topics that do not specifically fit into the other forums.

BBCode UID in signature lost when updating users in ACP

Postby baerenwurm » March 2nd 2013, 1:28 pm

Hi there.

Whenever I update users with BBCode in their signatures, the BBCode UID disappears from their "user_sig" field, i.e.
Code: Select all
[quote:57888c2d1d="randomuser"]
becomes
Code: Select all
[quote="randomuser"]
, thus disabling the BBCode.

Any idea why? :-( (I attached my admin_users.php.)
You do not have the required permissions to view the files attached to this post.
baerenwurm
New User
 
Posts: 21
Joined: February 27th 2003, 7:53 am

Re: BBCode UID in signature lost when updating users in ACP

Postby Thoul » March 4th 2013, 7:18 am

That attached file is includes/bbcode.php, based on the content, so you might want to check that you haven't overwritten your admin_users.php with it. :o

But, that said, I went through the file and didn't see anything that stands out as a cause of this. Aside from the various hacks to add new BBCodes, it looks like a standard bbcode.php. Even in the hacks, I didn't see anything that raises alarms.
User avatar
Thoul
Admin/Webmaster
 
Posts: 18551
Joined: July 30th 2002, 11:30 am
Location: USA

Re: BBCode UID in signature lost when updating users in ACP

Postby baerenwurm » March 4th 2013, 3:47 pm

Hi Thoul!

Thanks for helping me out here!

And: ops. I uploaded the wrong file (see attached file again). Plus, I think the "Always attach signature" option does reset itself to "No" aswell :blush:
You do not have the required permissions to view the files attached to this post.
baerenwurm
New User
 
Posts: 21
Joined: February 27th 2003, 7:53 am

Re: BBCode UID in signature lost when updating users in ACP

Postby Thoul » March 6th 2013, 7:54 am

Well, everything in that file looks perfectly normal and matches a default file as far as the signature settings go. Again, I see a few hacks - custom profile fields and the like - but they look to be installed correctly. They shouldn't be affecting the signature in any way that I can see.

There could be an issue in the prepare_message function in includes/functions_post.php. If that also matches a default file, I'm not sure where this issue could be arising from.
User avatar
Thoul
Admin/Webmaster
 
Posts: 18551
Joined: July 30th 2002, 11:30 am
Location: USA


Return to General phpBB 2 Support and Discussion

Who is online

Users browsing this forum: No registered users and 0 guests